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1  Introduction 

The software EyeFaceGUI is a desktop application, which demonstrates the use of EyeFace SDK, the 

software library for face detection, face analysis and face landmark detection. The program processes 

videos in various formats, resolution, and quality, it detects faces in them and applies advanced 

detection functions. Allows to use three types of video sources: video file, USB camera and IP stream. 

This software enables above all: 

- Open and play video files, USB camera streams, IP video streams. 

- Detect human faces in video, run face analysis (gender, age, ID) and detect face landmarks 

(eyes, eyebrows, nose, mouth, and chin) all in real-time. 

- Grab video frames to file. 

- Demonstration of EyeFace SDK functionality and performance. 

EyeFace SDK version info 

Each version of EyeFaceGUI reflects the used version of EyeFace SDK. Four version digits are used, 

first three are the same as used version of EyeFace SDK has, and the fourth digit is the version of 

EyeFaceGUI itself. 

This guide is written for the operation system Microsoft Windows 10, 64b, in English, in the default 

setting. Some of the described procedures and legends of the control elements of the operation system 

can differ for other operation systems. 
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2  Installation and Uninstallation of 
the Program 

2.1  Installation of the Program 

If you have installed the previous version of the application EyeFaceGUI, proceed in the same 

way as in the case of the first installation. Updating of all necessary files takes place during the 

installation. 

Installation of the program will start running the file EyeFaceGUISetup64.exe. After the 

installation of the required dependencies the following window will be displayed, it will 

inform on initiation of the installation process. 
 

 
 

Next, we will get using the button Next, a License Agreement will be displayed. 
 

 

After reading of the License Agreement and confirmation of the consent to it using the choice 

I accept the terms in the License Agreement it is possible to come to the next step using 

the Next button. 
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In this window, it is possible to change the folder alternatively, where the program will be 

installed, and using the button Next to come to a recapitulation before the installation. 

 

 

Now it is possible to start the installation itself with the button Install. This installation will 

copy all necessary files and if needed, it will also install a driver of a hardware key Sentinel. 
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If you want to use the IP stream as a video source, you need to install the VLC plugins. 

Due to different licensing conditions, VLC plugins are not the part of the EyeFaceGUI 

installation. Install the VLC plugins only if you agree with all the licenses. You can use the 

application without these plugins, but you will not be able to use the IP stream as a video source. 

The installation of the driver of the hardware key takes place automatically, but it requires 

a click a dialog after finishing the installation. 

 

The installer will display the following window after finishing the installation and it is possible 

to quit the installer using the button Finish. 

Now the program is installed and prepared for the first use.  
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2.2  Uninstallation 

It is possible to uninstall the program EyeFaceGUI using the shortcut in the menu Start 

(Start Menu ➞ All Programs ➞ Eyedea Recognition ➞ EyeFaceGUI ➞ Uninstall 

EyeFaceGUI), alternatively, using the Control Panel (Start Menu ➞ Control Panel ➞ 

Programs and Features). The driver for the hardware key (Sentinel Hardware keys 1.2.0 

(English)) will not be uninstalled during uninstallation of the program, because this part can be 

used also by other applications. 
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3  Main Features 
This chapter contains all main features of the application EyeFaceGUI. All supported types of 

video sources are described also with detailed instructions how to use them. Face detection, 

results displaying and EyeFace SDK settings are described below together with video 

configuration, video snapshots creation and application preferences. 

3.1  Open Video Source 

Three different types of video sources are available in 

EyeFaceGUI. First is USB camera, where all standard 

webcams are supported. Second is video IP stream, where 

all formats decodable by VLC are supported. The last one is 

video file, where all formats and containers decodable by 

FFmpeg are supported. All sources can be used to open and 

play video content along with performing face detection and 

analysis. 

3.1.1  Open Camera 

This type of source allows to open, play, and grab image data from a standard USB webcam. 

One of attached cameras can be selected as a video source also with one of the supported 

resolutions and frame rates. 

Camera dialog which is used for specific device and 

resolution selection can be opened using the action File → 

Open camera or by using the shortcut Ctrl+O. Dialog 

shows combo box used for camera device selection and the 

list containing all resolution supported by the current camera 

device. Selected setting can be confirmed using button OK. 

Then the video stream will be opened. 

If you connect the camera device when the dialog is already 

shown, you can refresh the camera list by pressing the 

Refresh button. 

3.1.2  Open IP Stream 

EyeFaceGUI allows you to use a video IP stream as a video source, where HTTP, RTP, RTSP 

and MMS protocols are supported. The IP stream dialog can be opened using the action File → 
Open IP Camera or using the shortcut Ctrl+I. The source URL can be entered directly in the 

field Address, or separately per 

each address part in fields 

Protocol, Server, Path, Port, 

Username, and Password. 

The stream will be opened and 

played after confirming the 

inserted values by pressing the 

button Open. 
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Install VLC plugins 

The IP stream playback functionality is provided by the libVLC library where the VLC plugins 

are required for basic functionality. These plugins are not the part of the EyeFaceGUI 

installation because of different licensing. If you want to use these plugins, you will need to 

download them during the installation otherwise you will be prompted to do so after opening 

IP stream in the application. Download and install the VLC plugins only if you agree with all 

the included licenses. 

 

The installation is performed automatically in command window after you confirm the 

acknowledgment. You need to be connected to the internet if you want to run the VLC plugins 

installation. You can start using the IP stream immediately after successful installation. If you 

do not agree with VLC plugins license terms or you do not want to install the plugins, you will 

be able to run the application, but the IP stream source will not be available. 

3.1.3  Open Video File 

Video file can be opened using the action File → Open file or using the shortcut Ctrl+L. 

Standard system file dialog opens and source video file can be selected. Immediately after the 

confirmation the playback starts. All video codecs and containers supported by FFmpeg are 

also supported by EyeFaceGUI.  
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3.2  Face Detection and Attributes Recognition 

EyeFaceGUI allows to analyze video stream and detect faces in it using the EyeFace SDK. 

Included advanced algorithms provides recognition of gender, age, and identity. All these 

operations are performed per frame and in real-time. All results are rendered in played video. 

The application also has an editor of EyeFace SDK ini files. 

3.2.1  Display Face Detection Results 

Face detection results displaying can be divided into four parts. Yaw angle of the face is 

described in Face detection. Whether the person looks into the camera belongs to the part 

Face attention. Face info contains data about gender, age and ID. Detecting important points 

on person’s face is described in Face landmarks. 

The Bounding rectangle is used for defining the rectangle of interest where the detector will 

look for faces. Advantage of this feature is the increase of detector performance due to smaller 

search space. 

Face Detection 

Face detection indicates the face itself and the yaw angle. It is 

the angle between the frontal face position and detected rotation. 

It is drawn as a rectangle around the detected face. The color of 

the rectangle depends on the detected gender, where male gender 

face has blue rectangle and female face has pink rectangle. 

Vertical sides of the rectangle are divided into two parts in the 

middle. These parts are skewed in response to the detected face 

angle. The higher the angle is the more the horizontal parts are 

skewed. 

This feature can be turned on and off using the menu Video → Show face detection. 
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Face Attention 

Face attention feature indicates whether the detected face looks into the 

camera. This feature can be turned on and off using the menu Video → 

Show face attention. The attention is indicated by the green rectangle 

around the detected face. The user can set an angular threshold on yaw 

angle (see the EyeFace SDK documentation), so that if the yaw angle is 

less than the threshold, the person is said to be in attention. 

Face Info 

Face info includes several detected values displayed together 

around the detected face. It can be turned on and off using the 

menu Video → Show face info. 

Detected age is placed below the face. The scale is used to show 

the detected age. It contains values between 0 and 80 indicating 

the detected age in years. 

Other recognized face attributes are placed next to the face 

on the left. On the top is the photo of the person which identifies 

the current face. EyeFace SDK contains a simple tracker to merge detections in subsequent 

images into tracks. The tracks aggregate information about detection and recognition in all 

previous frames. After a face disappears from the image, the tracks are stored. In case that a 

new face appears, the identity recognition tries to link it with previous tracks. 

The smile detection is placed under the identity photo. It shows whether the face is smiling 

or not using simple emoticon. On the bottom, the gender recognition result is displayed. 

The icon shows three possible gender signs: female, male and unknown gender. 

The detected distance from camera together with the ID of the person can be displayed below 

the age using the menu Video → Show additional info. Distance from camera indicates the 

approximate distance between the detected face and the camera in meters. 

Face Landmarks 

Facial landmarks such as eyes, nose and mouth can be detected using the 

EyeFace SDK. Currently 19 landmarks can be detected and displayed in 

EyeFaceGUI as white points on the detected face. Three points are located 

on each eyebrow, two points lies on each eye, four points define the nose 

and mouth and one point is located on the chin. 

This feature can be turned on using Video → Show face landmarks 
and must be enabled in the EyeFace SDK config file (see the EyeFace SDK Documentation). 

Bounding Rectangle 

Bounding rectangle allows the user to select the area where the 

detection should take place. It can be done by pressing the right 

mouse button on the video to define one corner of the rectangle 

and without releasing the button move the mouse to the position 

where the second corner defining the rectangle should be placed. 

After releasing the right mouse button, the rectangle is created. 

The bounding rectangle can be disabled by right clicking the 

video, using the action Video → Reset bounding box or using 

the shortcut R. 
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3.2.2  EyeFace SDK Settings 

EyeFace SDK allows to set many parameters which 

affects the recognition process (see the EyeFace 

SDK documentation). This configuration takes 

place in the ini file specified in the EyeFace SDK 

initialization. In EyeFaceGUI you can manage and 

modify these ini files and select the one which is 

used to initialize the EyeFace SDK. 

This configuration can be done using the action 

Preferences → EyeFace Settings which opens the 

ini file editor and manager. Using the combo box 

Active config, you can select the current ini file 

from the history which will be used. Button Open 

file allows you to select another ini file which will 

be opened in the editor below. All changes made to the ini file in the editor can be saved using 

the button Save. This action also reinitializes the EyeFace SDK with the currently selected ini 

file. 

3.2.3  Logging server 

EyeFace SDK contains a remote logging module, which enables the 

client to send the results using a HTTP POST requests over a network 

to a remote server. The server can be specified in the configuration file 

with several other options (see the EyeFace SDK documentation). This 

feature allows you to use remote server to log all faces tracked by the 

EyeFaceGUI. 

The server connection status is displayed in the top right corner of the video player surface. 

When the application is connected to server the status ‘connected’ is displayed. 

3.2.4  License Information 

The EyeFace SDK can be used with valid license only (see the 

EyeFace SDK documentation). To check the currently installed 

license, use the action Help → License info. The dialog will open 

where License ID and License Validity is displayed. 

3.3  Video Display Configuration 

Played and analyzed video can be modified using several actions which 

allows to display it in clearer and more comfort way. Video can be 

displayed in fullscreen and can be flipped both horizontally and 

vertically. All these features are available using the menu Video. 

3.3.1  Fullscreen 

The fullscreen feature allows you to display the video covering 

the full area of the screen to get clearer and detailed view of the 

analyzed video. Fullscreen can be turned on and off using the action 

Video → Fullscreen or using the shortcut F. 
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3.3.2  Horizontal and Vertical Flip 

Each played and analyzed video can be horizontally and vertically flipped. While the 

video frames are flipped right after reading from the source, this modification affects 

also the detection process. This feature is useful when source video is flipped around 

one or two axes due to physical position and configuration of the source camera. 

Horizontal flip can be turned on or off using the menu Video → Flip horizontally or using the 

shortcut H. Vertical flip can be activated using the menu Video → Flip vertically or using the 

shortcut V.  

3.4  Video Snapshots 

EyeFaceGUI allows to select between two methods of creating the video snapshots. First allows 

to take the screenshot of the video frame with all the information and graphics displayed. 

Second method grabs the raw source video frame in original resolution. 

3.4.1  Screenshot 

Screenshot action can be used to save the current video frame with all the displayed detections. 

Image is saved in JPEG format to the location specified in the Preferences (see the Chapter 3.5 ). 

Screenshot is saved in the resolution of the video rendering surface. This action can be 

activated using the menu Video → Take screenshot or by the shortcut S. 

3.4.2  Grab Video Frames 

The video frames can be grabbed using the special panel. This panel can be displayed 

and hidden using the menu View → Show photographing tab or by the shortcut P. This panel 

consist of several control elements. 

At the top is the input line where the path for saving the grabbed video frames can be selected 

using the button Choose. The input line for defining the subfolder is placed below. 
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In the middle of the panel the photo preview surface and the list of saved video frames 

are placed. List contains all the photos saved to the current path. Currently selected photo from 

the list is showed on the preview surface. 

At the bottom of the panel the elements controlling the grabbing are placed. The frame grabbing 

is started using the button Take photo. The grabbing parameters can be set using the two 

spinners placed on the right of the button. The spinner Sequence sets the number of the frames 

which should be grabbed in a sequence. The spinner Interval sets the interval between the 

grabbed frames in the sequence. All grabbed frames are saved separately in the PNG format. 

3.5  Application Preferences 

Several settings related to the application itself can be modified in the application preferences 

available under Preferences → Preferences or using the shortcut Ctrl+P. The default 

screenshot path (see the Chapter 3.4.1 ) can be defined, whether the last file/device should be 

opened on the application startup or whether the application should minimize to tray (see the 

Chapter 3.6 ). 

 

3.6  Tray Icon 

The tray icon serves as an indicator that the application is running. When the Minimize to tray 

is enabled (see the Chapter 3.5 ), the application always minimizes to the tray. EyeFaceGUI 

can be restored or hidden using the tray icon context menu or by double clicking the tray icon. 

 


